BES and Exchange hosting – Exchangemymail.com vs. LanLogic

After two days of fiddling with my email, I’m finally up and running on both Exchange and BES with all proper connections from my Outlook clients and my Blackberry.

Jake recommended I use LanLogic, but I researched other options and found that LanLogic is a little steep on the storage pricepoint compared to other vendors. Jake insisted that didn’t matter so much since their service is excellent, but I wasn’t so sure. Exchangemymail seemed to come highly recommended according to posts in the Blackberry Forums, plus they offered a small discount. So I went with Exchangemymail.com, not knowing that Jake actually did use them before going to LanLogic. I soon found out why, and went the same route he did.

  1. The signup for Exchangemymail went relatively smoothly, no issues there.
  2. (Problem 1) I logged in to my control panel and attempted to set up a user. The first try didn’t work – I got an error that the account wasn’t created. The second try didn’t either. The error was “Email address can not be created because registrar status of the domain is not ‘Ready’.” I created a support ticket and apparently the issue was on their end. They did some magic and I re-tried, successfully creating the account.
  3. I set up DNS (I’m using my own hosted DNS through DynDNS) according to the welcome email I got.
  4. I set up Outlook (2007) according to their documentation and it connected fine.
  5. I tested sending email from my client to my gMail account. Presto.
  6. (Problem 2) I replied from my gMail account…uh oh. I was getting a bounce-back error saying “544 No relaying allowed – psmtp”.
  7. (Problem 3) I created a BES account in my control panel and attempted to activate my Blackberry. No amount of trying was helping. I wiped it a gazillion times and retried.
  8. (Problem 4) I attempted to log in to the Postini control panel but kept getting the error “Invalid log in or server error. Please try again.”
  9. At this point I contacted support via the ticket system about the newest three problems. Their (pretty quick) response was that they were having problems with Postini which was likely the cause of all of my issues. About 90 minutes later I got an email from them stating they were able to add me to the system and I should try again.
  10. I could now send email to my new account from gMail, but I still couldn’t log in to Postini (no biggie, or so I thought) and my Blackberry wouldn’t activate.
  11. I ended up solving the activation problem myself my getting around the wireless activation by installing Desktop Manager, which really isn’t needed unless your wireless isn’t working, and activating it “wiredly”.
  12. Day two. (Problem 5) I realize that I can’t send mail to Jake. He can send mail to me, but my emails to him go into the Black Hole of Lost Email. I contact support again, explaining that he’s a former customer and it’s likely due to some setting they still have. Sure enough, that’s the case. Although they said it’s “normal” to keep old settings around…which I find odd. They removed the setting and asked me to try again. I tried again and it didn’t work.
  13. (Problem 6) I settle in to setting up my new domain’s website and the PHP form just won’t send mail to my address. Finally, I check the obvious and try sending mail to my gMail account instead of my EMM account and it works. Now, I’m pissed.
  14. (Problem 4 again) I tried logging in to Postini again thinking maybe it’s some sort of spam setting not allowing mail through from my site. No go.
  15. I tried sending mail to Jake again. No go.
  16. I wrote a final email to them:

At this point, I’m extremely dissatisfied with EMM.

1. I’m still not able to send emails to [Jake's domain].
2. Sending emails to my primary email account at EMM from a form on my website doesn’t work, but it does send to any other email address. I suspect this is related to Postini BUT
3. I can’t log in to Postini. Still. I mentioned this in the last ticket.

At this point I have to abandon your service and request a refund. I have wasted nearly two days of effort on your service, and while your response has typically been swift, I can’t afford any more delays.

Once my account is canceled, please remove all instances of Picobits.com from your system.

Angela

I signed up for LanLogic and was set up with my Exchange account immediately. I emailed them and asked for BES to be set up and Ted emailed me before I even had a chance to switch my DNS to the new servers asking me to switch them. I emailed him back and was set up with a BES account right away.

I still had wireless activation issues, the same issues as with EMM, but it wasn’t such a big deal since it was something I could fix myself anyway.

I got my refund, minus the “activation fees” from EMM.

Jake got to say, “I told you so.” And he was right.

  • Share/Bookmark

No related posts.

Related posts brought to you by Yet Another Related Posts Plugin.

1 Response to “BES and Exchange hosting – Exchangemymail.com vs. LanLogic”


  1. 1 furtivetelegram15.tblog.com

    Highly descriptive post, I enjoyed that a lot. Will there be
    a part 2?

Leave a Reply